Common issues include:
  • Did not meet prerequisites. You must login to as a user with sufficient write privileges to install RTI Enterprise, and to modify the application server’s startup script. Java runtime version 1.5 (or newer) must be installed before RTI Enterprise.
  • Be sure to enable RTI data collection as described in Section 1.3.3, “Enabling Your Applications for Monitoring”, and then restart your application server with the newly modified startup script.  RTI Enterprise should start collecting data, immediately.
  • Check $RTI_DATA/log on your Linux server for the presence of your RTI Enterprise data collectors.   Each active data collector should have a corresponding subdirectory containing *.apd and rti-*.txt files.
  • As described in Section 1.5, “Connecting the RTI Console to a Remote Performance Collector”, establish a New Host connection from RTI Console (on Windows or Mac) to your RTI Enterprise data collectors on Linux. The connection is created by a New Host Connection dialog, and be sure to Test the connection.   The dialog also contains $RTI_HOME path which must lead to your Linux server’s RTI Enterprise setup script, which defines the $RTI_DATA path.
  • If the RTI Console Collectors view shows a host whose connection seems broken, or whose collectors seem inactive, you can right-click to Delete the existing host from Collectors view.  Then establish it again by right-click to New Host.    Deleting a view from RTI Console does not erase the collected data on the remote Linux host.
Not seeing a collector:
  • If you don't see a collector for your JBoss, Tomcat or Fuse installation, then you may need to Refresh the host's view, if the collector was created since you launched the RTI Console.
  • If you still don't see your collector, then perhaps you didn't restart the application since you configured it. You must restart the application after using "rti edit..." to update its launch script.
Not getting data from a collector:
  • If a remote Linux RTI Enterprise installation seems to be working correctly and getting data, but Transaction Profile snapshot and other operations fail in the RTI Console, it could be that the connecting user doesn't have access to the RTI Enterprise data. This may be remedied by connecting as a different user, or as explained in Section 1.8, “Configuring RTI Enterprise to Run as a Different User”.


loading table of contents...